aboutsummaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-06-18 21:45:37 +0000
committerPetr Štetiar <ynezz@true.cz>2019-06-21 15:23:49 +0200
commit83c0ee621b8df6b8b5a90629d2ba610a927c050c (patch)
treeddf616150305c65b92edadd69bb8bef078076681 /include/toplevel.mk
parent3ead9e7b743b1fbd3b07f5a72a16999abbec9347 (diff)
downloadupstream-83c0ee621b8df6b8b5a90629d2ba610a927c050c.tar.gz
upstream-83c0ee621b8df6b8b5a90629d2ba610a927c050c.tar.bz2
upstream-83c0ee621b8df6b8b5a90629d2ba610a927c050c.zip
build: fix kernel_*config targets on 4.19
Recent kernel versions need toolchain in order to properly configure kernel, for example to set CC_HAS_ASM_GOTO config symbol, so missing toolchain leads to the following error while running `make kernel_oldconfig` on ath79 target with 4.19 kernel in the clean tree: init/Kconfig:17: syntax error init/Kconfig:16: invalid option ./scripts/clang-version.sh: line 15: mips-openwrt-linux-musl-gcc: command not found ./scripts/gcc-plugin.sh: line 11: mips-openwrt-linux-musl-gcc: command not found net/sched/Kconfig:44: warning: menuconfig statement without prompt make[4]: *** [scripts/kconfig/Makefile:69: oldconfig] Error 1 So in order to support this new kernel versions, this patch adds toolchain as a hard dependency to the kernel_*config targets. Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com> Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 36f790f807..133da9d830 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -145,7 +145,7 @@ xconfig: scripts/config/qconf prepare-tmpinfo FORCE
fi
$< Config.in
-prepare_kernel_conf: .config FORCE
+prepare_kernel_conf: .config toolchain/install FORCE
ifeq ($(wildcard staging_dir/host/bin/quilt),)
prepare_kernel_conf: