aboutsummaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorAlif M. Ahmad <alive4ever@live.com>2017-07-23 03:08:56 +0000
committerFelix Fietkau <nbd@nbd.name>2017-11-02 15:58:45 +0100
commit23dd6db2ea6d783c16bf10b43c23478b7f26723d (patch)
treeb91295ef22a54a17fd1e70800029ef06791a766c /include/toplevel.mk
parentb1501a684bdbe0c6d09017cc0773c109ca44b2e7 (diff)
downloadupstream-23dd6db2ea6d783c16bf10b43c23478b7f26723d.tar.gz
upstream-23dd6db2ea6d783c16bf10b43c23478b7f26723d.tar.bz2
upstream-23dd6db2ea6d783c16bf10b43c23478b7f26723d.zip
include/toplevel.mk: Add xconfig target
Add xconfig target to include/toplevel.mk, so that ``make xconfig`` can be invoked from $TOPDIR to use Qt based configuration tool to prepare .config file. The qconf related sources are taken from linux 4.9.13 archive. Signed-off-by: Alif M. Ahmad <alive4ever@live.com>
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 658eb4ce47..3f5a750030 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -104,6 +104,9 @@ scripts/config/mconf:
$(eval $(call rdep,scripts/config,scripts/config/mconf))
+scripts/config/qconf:
+ @$(_SINGLE)$(SUBMAKE) -s -C scripts/config qconf CC="$(HOSTCC_WRAPPER)"
+
scripts/config/conf:
@$(_SINGLE)$(SUBMAKE) -s -C scripts/config conf CC="$(HOSTCC_WRAPPER)"
@@ -136,6 +139,12 @@ menuconfig: scripts/config/mconf prepare-tmpinfo FORCE
[ -L .config ] && export KCONFIG_OVERWRITECONFIG=1; \
$< Config.in
+xconfig: scripts/config/qconf prepare-tmpinfo FORCE
+ if [ \! -e .config -a -e $(HOME)/.openwrt/defconfig ]; then \
+ cp $(HOME)/.openwrt/defconfig .config; \
+ fi
+ $< Config.in
+
prepare_kernel_conf: .config FORCE
ifeq ($(wildcard staging_dir/host/bin/quilt),)