aboutsummaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-08-07 00:04:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-08-07 00:04:25 +0000
commitd10a56dc58f6c601a9abaddbe1e9cfe4db97d57b (patch)
tree9cda5ecf22a01d8a2ac22cd1a6510d51dfd5f3c3 /include/toplevel.mk
parenta46bd6cee4e494a5879393349c2a6990996c5904 (diff)
downloadupstream-d10a56dc58f6c601a9abaddbe1e9cfe4db97d57b.tar.gz
upstream-d10a56dc58f6c601a9abaddbe1e9cfe4db97d57b.tar.bz2
upstream-d10a56dc58f6c601a9abaddbe1e9cfe4db97d57b.zip
build system cleanup/restructuring as described in http://lists.openwrt.org/pipermail/openwrt-devel/2007-August/001159.html
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8362 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index af4b390e4e..e456264221 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -94,7 +94,7 @@ download: .config FORCE
$(MAKE) -j1 package/download
$(MAKE) -j1 target/download
-clean dirclean distclean:
+clean dirclean:
@$(MAKE) $@
prereq:: .config
@@ -118,6 +118,9 @@ symlinkclean:
-find package -type l | xargs rm -f
rm -rf tmp
+distclean:
+ rm -rf tmp build_dir staging_dir dl .config*
+
ifeq ($(findstring v,$(DEBUG)),)
.SILENT: symlinkclean clean dirclean distclean config-clean download help tmpinfo-clean .config scripts/config/mconf scripts/config/conf menuconfig tmp/.prereq-build tmp/.prereq-package tmp/.prereq-target prepare-tmpinfo
endif