aboutsummaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-03 15:08:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-03 15:08:55 +0000
commit2abf9f5f94b314468509546917e53d85efd94f05 (patch)
tree9dc7e4d7f6033a07d46863a13e5cf027407065f9 /include/toplevel.mk
parent937f1820f2936d3940240b1cb77b094fd4086df9 (diff)
downloadupstream-2abf9f5f94b314468509546917e53d85efd94f05.tar.gz
upstream-2abf9f5f94b314468509546917e53d85efd94f05.tar.bz2
upstream-2abf9f5f94b314468509546917e53d85efd94f05.zip
optimize the .config dependency chain in the toplevel makefile
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14740 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 7f5308fc26..9dfc9dfc2f 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -49,7 +49,7 @@ prepare-tmpinfo: FORCE
./scripts/metadata.pl package_mk tmp/.packageinfo > tmp/.packagedeps || { rm -f tmp/.packagedeps; false; }
touch $(TOPDIR)/tmp/.build
-.config: ./scripts/config/conf prepare-tmpinfo $(if $(CONFIG_HAVE_DOT_CONFIG),,FORCE)
+.config: ./scripts/config/conf $(if $(CONFIG_HAVE_DOT_CONFIG),,prepare-tmpinfo)
@+if [ \! -e .config ] || ! grep CONFIG_HAVE_DOT_CONFIG .config >/dev/null; then \
[ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
$(_SINGLE)$(NO_TRACE_MAKE) menuconfig $(PREP_MK); \
@@ -106,7 +106,7 @@ download: .config FORCE
clean dirclean: .config
@+$(SUBMAKE) -r $@
-prereq:: .config
+prereq:: prepare-tmpinfo .config
@+$(MAKE) -r -s tmp/.prereq-build $(PREP_MK)
@+$(NO_TRACE_MAKE) -r -s $@