aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2018-12-16 10:45:53 +0100
committerZoltan HERPAI <wigyori@uid0.hu>2023-06-14 09:22:08 +0200
commit341e312ada4dda207a9f2c8402e73cc13b195983 (patch)
tree130d56e4e1773032cda3f7fe10c8d53342f37083 /include/target.mk
parent848759c2362fc60fef8aa76f2adeb228af3cae65 (diff)
downloadupstream-341e312ada4dda207a9f2c8402e73cc13b195983.tar.gz
upstream-341e312ada4dda207a9f2c8402e73cc13b195983.tar.bz2
upstream-341e312ada4dda207a9f2c8402e73cc13b195983.zip
generic: groundwork for RISC-V
Add build infrastructure for RISC-V. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> (cherry picked from commit 50c05f6cd721130701cbbc77a75d2e090259c4e5)
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index 992f955344..b5e3e7ff6f 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -260,6 +260,10 @@ ifeq ($(DUMP),1)
CPU_CFLAGS_arc700 = -mcpu=arc700
CPU_CFLAGS_archs = -mcpu=archs
endif
+ ifeq ($(ARCH),riscv64)
+ CPU_TYPE ?= riscv64
+ CPU_CFLAGS_riscv64:=-mabi=lp64d -march=rv64imafdc
+ endif
ifneq ($(CPU_TYPE),)
ifndef CPU_CFLAGS_$(CPU_TYPE)
$(warning CPU_TYPE "$(CPU_TYPE)" doesn't correspond to a known type)