aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-05-29 18:40:03 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-06-03 15:41:09 +0200
commit057e5f6edee34e6bbd49dfe6f9944a3ba1936719 (patch)
treeef2a2c19840ed3c19b90bc49123f4b7d6e228744 /include/target.mk
parent64ebf74c059f72e91cbed1030d4609b573992295 (diff)
downloadupstream-057e5f6edee34e6bbd49dfe6f9944a3ba1936719.tar.gz
upstream-057e5f6edee34e6bbd49dfe6f9944a3ba1936719.tar.bz2
upstream-057e5f6edee34e6bbd49dfe6f9944a3ba1936719.zip
treewide: provide consistent basic DEVICE_TYPE
While the effective "default" based on frequent use is "router", the DEVICE_TYPE variable actually provides a "basic" configuration without selecting any additional packages. This is currently set up with the identifier "bootloader", which seems to be not used at all. However, the only targets not using "router" or "nas" are actually archs38 and arc770, which use their own value "developerboard" for DEVICE_TYPE which seems to have been invented when these targets where added. The latter is not implemented in target.mk, though, and will fall back to the "basic" set of packages then. So, to clean this up and make it more readable, let's just define a DEVICE_TYPE "basic" and use it for the aforementioned cases. Cc: Christian Lamparter <chunkeey@gmail.com> Cc: Sungbo Eo <mans0n@gorani.run> Cc: Linus Walleij <linus.walleij@linaro.org> Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/target.mk b/include/target.mk
index 9bd4c14936..a2ceb7f783 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -14,11 +14,12 @@ DEVICE_TYPE?=router
# Default packages - the really basic set
DEFAULT_PACKAGES:=base-files libc libgcc busybox dropbear mtd uci opkg netifd fstools uclient-fetch logd urandom-seed urngd
+# For the basic set
+DEFAULT_PACKAGES.basic:=
# For nas targets
DEFAULT_PACKAGES.nas:=block-mount fdisk lsblk mdadm
# For router targets
DEFAULT_PACKAGES.router:=dnsmasq iptables ip6tables ppp ppp-mod-pppoe firewall odhcpd-ipv6only odhcp6c kmod-ipt-offload
-DEFAULT_PACKAGES.bootloader:=
ifneq ($(DUMP),)
all: dumpinfo