aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-07-04 13:41:50 +0000
committerJonas Gorski <jogo@openwrt.org>2013-07-04 13:41:50 +0000
commitf541a0e76bb21be76ccbbe3cd09b7c2fe7f38965 (patch)
treeaa84d8b329c218c54bedf6ee654995213a352bae /include/target.mk
parent7b811a589c9201d01740eafa296a6f99edc2e855 (diff)
downloadupstream-f541a0e76bb21be76ccbbe3cd09b7c2fe7f38965.tar.gz
upstream-f541a0e76bb21be76ccbbe3cd09b7c2fe7f38965.tar.bz2
upstream-f541a0e76bb21be76ccbbe3cd09b7c2fe7f38965.zip
include: also check CONFIG_GPIOLIB for GPIO_SUPPORT
Recent kernels removed GENERIC_GPIO and require GPIO capable targets to select GPIOLIB instead, so check for both symbols. Fixed #13814. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37166 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/target.mk b/include/target.mk
index 7a704e2206..eeabb25f37 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -163,7 +163,7 @@ ifeq ($(DUMP),1)
.SILENT: $(TMP_CONFIG)
.PRECIOUS: $(TMP_CONFIG)
- ifneq ($(CONFIG_GENERIC_GPIO),)
+ ifneq ($(CONFIG_GENERIC_GPIO)$(CONFIG_GPIOLIB),)
FEATURES += gpio
endif
ifneq ($(CONFIG_PCI),)