aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-04-23 16:10:25 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-04-23 16:10:25 +0000
commitbb5d3388bea94ac2502758c89be65c0cf6b4a865 (patch)
tree8fa5c9173b2af8a75ff994e1bc5df6d32eb0a7eb /include/target.mk
parentd7054176d9a5d08a2ac23f819bd046ced34eb875 (diff)
downloadupstream-bb5d3388bea94ac2502758c89be65c0cf6b4a865.tar.gz
upstream-bb5d3388bea94ac2502758c89be65c0cf6b4a865.tar.bz2
upstream-bb5d3388bea94ac2502758c89be65c0cf6b4a865.zip
[include] ensure that profile Makefiles are sourced in alphabetical order
Since make 3.82 does not guarantee file ordering anymore, target profiles might get included in random order, leading to bad default values when only selecting the toplevel target and populating the .config with defconfig. This commit should also fix the ar71xx snapshot builds. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31449 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/target.mk b/include/target.mk
index 097b275cf2..e5166fb784 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -84,12 +84,12 @@ endif
ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
define IncludeProfiles
- -include $(PLATFORM_DIR)/profiles/*.mk
- -include $(PLATFORM_SUBDIR)/profiles/*.mk
+ -include $(sort $(wildcard $(PLATFORM_DIR)/profiles/*.mk))
+ -include $(sort $(wildcard $(PLATFORM_SUBDIR)/profiles/*.mk))
endef
else
define IncludeProfiles
- -include $(PLATFORM_DIR)/profiles/*.mk
+ -include $(sort $(wildcard $(PLATFORM_DIR)/profiles/*.mk))
endef
endif