aboutsummaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2021-11-04 15:53:50 +0100
committerFelix Fietkau <nbd@nbd.name>2021-11-04 16:43:32 +0100
commit94b0849c19848beda9e1a215bcae0daac6927ff0 (patch)
tree9e11fcad72228d0ba6d17cd9353b45f5522ed4cd /include/subdir.mk
parentf4323538501d58298f4df73a034a51375a477cfc (diff)
downloadupstream-94b0849c19848beda9e1a215bcae0daac6927ff0.tar.gz
upstream-94b0849c19848beda9e1a215bcae0daac6927ff0.tar.bz2
upstream-94b0849c19848beda9e1a215bcae0daac6927ff0.zip
build: add SUBDIR_MAKE_DEBUG variable to make it easier to debug package makefiles
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index d33b947fdf..155f493538 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -27,7 +27,7 @@ lastdir=$(word $(words $(subst /, ,$(1))),$(subst /, ,$(1)))
diralias=$(if $(findstring $(1),$(call lastdir,$(1))),,$(call lastdir,$(1)))
subdir_make_opts = \
- -r -C $(1) \
+ $(if $(SUBDIR_MAKE_DEBUG),-d) -r -C $(1) \
BUILD_SUBDIR="$(1)" \
BUILD_VARIANT="$(4)" \
ALL_VARIANTS="$(5)"