aboutsummaryrefslogtreecommitdiffstats
path: root/include/scan.mk
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2023-05-25 02:31:17 -0400
committerPetr Štetiar <ynezz@true.cz>2023-06-12 22:10:20 +0200
commit948dc515dc5afca45a233471535e7c463866c9a9 (patch)
treea3ab265dc98c7cf7970ad3e5a49fc77324f600c7 /include/scan.mk
parent145d485d51330c40deccce8e249a1da4b1c283ca (diff)
downloadupstream-948dc515dc5afca45a233471535e7c463866c9a9.tar.gz
upstream-948dc515dc5afca45a233471535e7c463866c9a9.tar.bz2
upstream-948dc515dc5afca45a233471535e7c463866c9a9.zip
treewide: add ORIG_PATH variable
Add a variable that stores the original value of $PATH in the host system's shell, before Make alters it. This can be useful for when it is necessary to ignore symlinks and programs made by the build system. Define this new variable before all instances of 'export PATH:=' or similar. Signed-off-by: Michael Pratt <mcpratt@pm.me> (cherry picked from commit d87a8aa148ddf93b199a759deb088fff73787025)
Diffstat (limited to 'include/scan.mk')
-rw-r--r--include/scan.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/scan.mk b/include/scan.mk
index 12ef5d1dc7..33a5832ff5 100644
--- a/include/scan.mk
+++ b/include/scan.mk
@@ -11,6 +11,7 @@ TARGET_STAMP:=$(TMP_DIR)/info/.files-$(SCAN_TARGET).stamp
FILELIST:=$(TMP_DIR)/info/.files-$(SCAN_TARGET)-$(SCAN_COOKIE)
OVERRIDELIST:=$(TMP_DIR)/info/.overrides-$(SCAN_TARGET)-$(SCAN_COOKIE)
+export ORIG_PATH:=$(if $(ORIG_PATH),$(ORIG_PATH),$(PATH))
export PATH:=$(STAGING_DIR_HOST)/bin:$(PATH)
define feedname