aboutsummaryrefslogtreecommitdiffstats
path: root/include/scan.mk
diff options
context:
space:
mode:
authorLeo Chung <gewalalb@gmail.com>2022-03-31 09:14:35 +0800
committerChristian 'Ansuel' Marangi <ansuelsmth@gmail.com>2022-06-05 15:38:27 +0200
commiteb787b5b9d8d45f3678b58eaa158bb4fa28d4418 (patch)
tree993a513488e61b31257329c4a41f7908666674b4 /include/scan.mk
parent3fbf9689b652e230e21bbc7ab2a9b8c936bd6e80 (diff)
downloadupstream-eb787b5b9d8d45f3678b58eaa158bb4fa28d4418.tar.gz
upstream-eb787b5b9d8d45f3678b58eaa158bb4fa28d4418.tar.bz2
upstream-eb787b5b9d8d45f3678b58eaa158bb4fa28d4418.zip
build: fix find warning with SCAN_EXTRA
If you change SCAN_EXTRA variable with "-path target/linux/xxxx" in include/toplevel.mk for speed up scan, find will warn with: find: warning: you have specified the global option -maxdepth after the argument -path, but global options are not positional, i.e., -maxdepth affects tests specified before it as well as those specified after it. Please specify global options before other arguments. The find option -mindepth -maxdepth are global options and must be before any path option. Change order of $(SCAN_EXTRA) after -mindepth and -maxdepth to fix this. Signed-off-by: Leo Chung <gewalalb@gmail.com> [capitalize Description, Author and Sob and minor description tweak] Signed-off-by: Christian 'Ansuel' Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'include/scan.mk')
-rw-r--r--include/scan.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/scan.mk b/include/scan.mk
index aee24cb3e5..5032afa818 100644
--- a/include/scan.mk
+++ b/include/scan.mk
@@ -72,7 +72,7 @@ endif
$(FILELIST): $(OVERRIDELIST)
rm -f $(TMP_DIR)/info/.files-$(SCAN_TARGET)-*
- find -L $(SCAN_DIR) $(SCAN_EXTRA) -mindepth 1 $(if $(SCAN_DEPTH),-maxdepth $(SCAN_DEPTH)) -name Makefile | xargs grep -aHE 'call $(GREP_STRING)' | sed -e 's#^$(SCAN_DIR)/##' -e 's#/Makefile:.*##' | uniq | awk -v of=$(OVERRIDELIST) -f include/scan.awk > $@
+ find -L $(SCAN_DIR) -mindepth 1 $(if $(SCAN_DEPTH),-maxdepth $(SCAN_DEPTH)) $(SCAN_EXTRA) -name Makefile | xargs grep -aHE 'call $(GREP_STRING)' | sed -e 's#^$(SCAN_DIR)/##' -e 's#/Makefile:.*##' | uniq | awk -v of=$(OVERRIDELIST) -f include/scan.awk > $@
$(TMP_DIR)/info/.files-$(SCAN_TARGET).mk: $(FILELIST)
( \