aboutsummaryrefslogtreecommitdiffstats
path: root/include/scan.mk
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2022-12-02 20:56:12 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-01-09 21:33:20 +0100
commit2a3283643ccf77b55d67c7a3f96d40576227499c (patch)
tree46678ed84d5d237d81b4a50c86fd1fe3baf09e1e /include/scan.mk
parentd10e6591d1523738852dd0ab625df1f9ea7fc63c (diff)
downloadupstream-2a3283643ccf77b55d67c7a3f96d40576227499c.tar.gz
upstream-2a3283643ccf77b55d67c7a3f96d40576227499c.tar.bz2
upstream-2a3283643ccf77b55d67c7a3f96d40576227499c.zip
treewide: derive host and hostpkg path from STAGING_DIR
STAGING_DIR may be provided from command line. We currently hardcoded STAGING_DIR_HOST and STAGING_DIR_HOSTPKG to the default location but we currently have some relocatable patch that derive the path from STAGING_DIR. Fix this and correctly derive STAGING_DIR_HOST and STAGING_DIR_HOSTPKG from STAGING_DIR. The intention is to fix inconsistency from the relocatable patch and the use of STAGING_DIR_HOST that is always hardcoded. This with a wrong configuration may end up in broken state with some host tools expecing a PATH from STAGING_DIR and others using library from the default staging_dir/host path. To save downstream project the original implementation is saved while fixing the inconsistency between patch and .mk. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'include/scan.mk')
-rw-r--r--include/scan.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/scan.mk b/include/scan.mk
index 5032afa818..12ef5d1dc7 100644
--- a/include/scan.mk
+++ b/include/scan.mk
@@ -11,7 +11,7 @@ TARGET_STAMP:=$(TMP_DIR)/info/.files-$(SCAN_TARGET).stamp
FILELIST:=$(TMP_DIR)/info/.files-$(SCAN_TARGET)-$(SCAN_COOKIE)
OVERRIDELIST:=$(TMP_DIR)/info/.overrides-$(SCAN_TARGET)-$(SCAN_COOKIE)
-export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH)
+export PATH:=$(STAGING_DIR_HOST)/bin:$(PATH)
define feedname
$(if $(patsubst feeds/%,,$(1)),,$(word 2,$(subst /, ,$(1))))