aboutsummaryrefslogtreecommitdiffstats
path: root/include/scan.mk
diff options
context:
space:
mode:
authorR. Diez <rdiezmail-openwrt@yahoo.com>2019-01-21 18:32:06 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2019-02-17 19:22:04 +0100
commiteabc1ddc4541019cf3e4c10b3a15c0710d87bca3 (patch)
tree2db349bc57e8eeccdbe78e53f3d952b49521da20 /include/scan.mk
parent55b808e0c4be681a0aab565d32a70f5af06a1f8a (diff)
downloadupstream-eabc1ddc4541019cf3e4c10b3a15c0710d87bca3.tar.gz
upstream-eabc1ddc4541019cf3e4c10b3a15c0710d87bca3.tar.bz2
upstream-eabc1ddc4541019cf3e4c10b3a15c0710d87bca3.zip
build: Honour NO_COLOR in include/scan.mk
The sender domain has a DMARC Reject/Quarantine policy which disallows sending mailing list messages using the original "From" header. To mitigate this problem, the original message has been wrapped automatically by the mailing list software. Hi all: This is my first OpenWrt patch. I am a clean, pure newbie! 8-) Honour NO_COLOR in Makefile function 'progress' in include/scan.mk, in the same way that include/verbose.mk does. Signed-off-by: R. Diez <rdiezmail-openwrt@yahoo.com>
Diffstat (limited to 'include/scan.mk')
-rw-r--r--include/scan.mk10
1 files changed, 8 insertions, 2 deletions
diff --git a/include/scan.mk b/include/scan.mk
index e6b21b27b0..724dbfaf17 100644
--- a/include/scan.mk
+++ b/include/scan.mk
@@ -19,9 +19,15 @@ else
endif
ifeq ($(IS_TTY),1)
- define progress
+ ifneq ($(strip $(NO_COLOR)),1)
+ define progress
printf "\033[M\r$(1)" >&2;
- endef
+ endef
+ else
+ define progress
+ :;
+ endef
+ endif
else
define progress
:;