aboutsummaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-03 14:55:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-03 14:55:53 +0000
commit937f1820f2936d3940240b1cb77b094fd4086df9 (patch)
treecb5eba0e4f6e22e81665e3ef321d102d1ca321fc /include/quilt.mk
parenta01125e51b4c7e66db0fc72bf8d10698e4f536c6 (diff)
downloadupstream-937f1820f2936d3940240b1cb77b094fd4086df9.tar.gz
upstream-937f1820f2936d3940240b1cb77b094fd4086df9.tar.bz2
upstream-937f1820f2936d3940240b1cb77b094fd4086df9.zip
replace a few unnecessary $(shell) calls
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14739 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index c5245a8aee..0d63e62fd2 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -56,7 +56,7 @@ $(call PatchDir/$(if $(strip $(QUILT)),Quilt,Default),$(strip $(1)),$(strip $(2)
endef
ifneq ($(PKG_BUILD_DIR),)
- QUILT?=$(strip $(shell test -f $(PKG_BUILD_DIR)/.quilt_used && echo y))
+ QUILT?=$(if $(wildcard $(PKG_BUILD_DIR)/.quilt_used),y)
ifneq ($(QUILT),)
STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
STAMP_CHECKED:=$(PKG_BUILD_DIR)/.quilt_checked
@@ -67,7 +67,7 @@ ifneq ($(PKG_BUILD_DIR),)
endif
ifneq ($(HOST_BUILD_DIR),)
- HOST_QUILT?=$(strip $(shell test -f $(if $(PKG_BUILD_DIR),$(PKG_BUILD_DIR),$(HOST_BUILD_DIR))/.quilt_used && echo y))
+ HOST_QUILT?=$(if $(wildcard $(if $(PKG_BUILD_DIR),$(PKG_BUILD_DIR),$(HOST_BUILD_DIR))/.quilt_used),y)
ifneq ($(HOST_QUILT),)
HOST_STAMP_PATCHED:=$(HOST_BUILD_DIR)/.quilt_patched
HOST_STAMP_CHECKED:=$(HOST_BUILD_DIR)/.quilt_checked