aboutsummaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorMichal Hrusecky <michal.hrusecky@nic.cz>2018-10-11 18:23:19 +0200
committerJo-Philipp Wich <jo@mein.io>2019-01-30 13:20:14 +0100
commit37e91861cc6b1988531e2c68131d65053e7dd230 (patch)
tree79b0bee628e66cdf0dda5f35a2ab36f436475f23 /include/quilt.mk
parent19850b639e445b6c13e8fa47cf9745fa617f53eb (diff)
downloadupstream-37e91861cc6b1988531e2c68131d65053e7dd230.tar.gz
upstream-37e91861cc6b1988531e2c68131d65053e7dd230.tar.bz2
upstream-37e91861cc6b1988531e2c68131d65053e7dd230.zip
build: Use LINUX_DIR for Kernel/Patch
Use LINUX_DIR as a path when patching kernel. Doesn't break the current usage, but allows to create packages that will contain variation of a kernel with kernel being build in some subdirectory of PKG_BUILD_DIR. Signed-off-by: Michal Hrusecky <michal.hrusecky@nic.cz>
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index 61dcc7964c..56f674a2f3 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -94,17 +94,17 @@ endef
kernel_files=$(foreach fdir,$(GENERIC_FILES_DIR) $(FILES_DIR),$(fdir)/.)
define Kernel/Patch/Default
- $(if $(QUILT),rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches)
+ $(if $(QUILT),rm -rf $(LINUX_DIR)/patches; mkdir -p $(LINUX_DIR)/patches)
$(if $(kernel_files),$(CP) $(kernel_files) $(LINUX_DIR)/)
find $(LINUX_DIR)/ -name \*.rej -or -name \*.orig | $(XARGS) rm -f
if [ -d $(GENERIC_PLATFORM_DIR)/patches$(if $(wildcard $(GENERIC_PLATFORM_DIR)/patches-$(KERNEL_PATCHVER)),-$(KERNEL_PATCHVER)) ]; then \
echo "generic patches directory is present. please move your patches to the pending directory" ; \
exit 1; \
fi
- $(call PatchDir,$(PKG_BUILD_DIR),$(GENERIC_BACKPORT_DIR),generic-backport/)
- $(call PatchDir,$(PKG_BUILD_DIR),$(GENERIC_PATCH_DIR),generic/)
- $(call PatchDir,$(PKG_BUILD_DIR),$(GENERIC_HACK_DIR),generic-hack/)
- $(call PatchDir,$(PKG_BUILD_DIR),$(PATCH_DIR),platform/)
+ $(call PatchDir,$(LINUX_DIR),$(GENERIC_BACKPORT_DIR),generic-backport/)
+ $(call PatchDir,$(LINUX_DIR),$(GENERIC_PATCH_DIR),generic/)
+ $(call PatchDir,$(LINUX_DIR),$(GENERIC_HACK_DIR),generic-hack/)
+ $(call PatchDir,$(LINUX_DIR),$(PATCH_DIR),platform/)
endef
define Quilt/RefreshDir