aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorTony Butler <spudz76@gmail.com>2022-12-02 12:05:08 -0800
committerChristian Marangi <ansuelsmth@gmail.com>2022-12-06 23:53:45 +0100
commitf595bebc7fc67255dc05ec4c1b74b0349c1d2aa3 (patch)
tree8a41108156257e03d3e69be41d19676091d7e648 /include/prereq-build.mk
parent42f0ab028e2eae0d4e7acf9db7fd68b256f23503 (diff)
downloadupstream-f595bebc7fc67255dc05ec4c1b74b0349c1d2aa3.tar.gz
upstream-f595bebc7fc67255dc05ec4c1b74b0349c1d2aa3.tar.bz2
upstream-f595bebc7fc67255dc05ec4c1b74b0349c1d2aa3.zip
build: add gzip to prereq-build.mk
gzip has never been checked for, a system without it would be rare, fix it anyway Signed-off-by: Tony Butler <spudz76@gmail.com>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index c5c2f1c8bb..9c4ef547ad 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -149,6 +149,9 @@ $(eval $(call SetupHostCommand,stat,Cannot find a file stat utility, \
gstat -c%s $(TOPDIR)/Makefile, \
stat -c%s $(TOPDIR)/Makefile))
+$(eval $(call SetupHostCommand,gzip,Please install 'gzip', \
+ gzip --version </dev/null))
+
$(eval $(call SetupHostCommand,unzip,Please install 'unzip', \
unzip 2>&1 | grep zipfile, \
unzip))