aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorOscar Molnar <oscar@tymscar.com>2022-08-06 16:13:41 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-08-13 21:13:08 +0200
commita9e8eec221874e5840d659aed3f68850ff1d9982 (patch)
tree350695c8f3a39f2bcb57a854fa117f38cdbe34b7 /include/prereq-build.mk
parent24307b035143bc710268590850e595e1fad86f08 (diff)
downloadupstream-a9e8eec221874e5840d659aed3f68850ff1d9982.tar.gz
upstream-a9e8eec221874e5840d659aed3f68850ff1d9982.tar.bz2
upstream-a9e8eec221874e5840d659aed3f68850ff1d9982.zip
build: add support for python3.11 and higher
python3.11 beta is out but fails to run the makefile currently this supports python versions from 3.6 to 3.99 with the python3 binary it also checks specifically for 3.11 as it is the latest version out Signed-off-by: Oscar Molnar <oscar@tymscar.com>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 7428c21e16..6c45327f01 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -169,20 +169,22 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
$(eval $(call CleanupPython2))
$(eval $(call SetupHostCommand,python,Please install Python >= 3.6, \
+ python3.11 -V 2>&1 | grep 'Python 3', \
python3.10 -V 2>&1 | grep 'Python 3', \
python3.9 -V 2>&1 | grep 'Python 3', \
python3.8 -V 2>&1 | grep 'Python 3', \
python3.7 -V 2>&1 | grep 'Python 3', \
python3.6 -V 2>&1 | grep 'Python 3', \
- python3 -V 2>&1 | grep -E 'Python 3\.([6-9]|10)\.?'))
+ python3 -V 2>&1 | grep -E 'Python 3\.([6-9]|[0-9][0-9])\.?'))
$(eval $(call SetupHostCommand,python3,Please install Python >= 3.6, \
+ python3.11 -V 2>&1 | grep 'Python 3', \
python3.10 -V 2>&1 | grep 'Python 3', \
python3.9 -V 2>&1 | grep 'Python 3', \
python3.8 -V 2>&1 | grep 'Python 3', \
python3.7 -V 2>&1 | grep 'Python 3', \
python3.6 -V 2>&1 | grep 'Python 3', \
- python3 -V 2>&1 | grep -E 'Python 3\.([6-9]|10)\.?'))
+ python3 -V 2>&1 | grep -E 'Python 3\.([6-9]|[0-9][0-9])\.?'))
$(eval $(call TestHostCommand,python3-distutils, \
Please install the Python3 distutils module, \