aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2022-08-30 08:45:39 +0200
committerPetr Štetiar <ynezz@true.cz>2022-09-06 08:04:53 +0200
commiteae2fb8027cb892e42181e471ba344aa5d26bf7e (patch)
tree9f73987734e960912d3a463e1bc46019e0cc7c54 /include/prereq-build.mk
parent06e01e817ec6643a35beb9e6946689e9cc7d020a (diff)
downloadupstream-eae2fb8027cb892e42181e471ba344aa5d26bf7e.tar.gz
upstream-eae2fb8027cb892e42181e471ba344aa5d26bf7e.tar.bz2
upstream-eae2fb8027cb892e42181e471ba344aa5d26bf7e.zip
build: provide xxd -i with scripts/xxdi.pl
Dependency on xxd was added in commit c4dd2441e787 ("tools: add xxd (from vim)") as U-Boot requires xxd to create the default environment from an external file. Later in commit 2b94aac7a128 ("tools: xxd: use more convenient source tarball"), xxd from another source was used instead, but that source is currently unavailable, so let's fix it by using simple xxdi.pl Perl script instead. Fixes: #10555 Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 6c45327f01..0a023c2c6f 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -202,7 +202,10 @@ $(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
mkdir -p $(dir $@)
$(CC) -O2 -I$(TOPDIR)/tools/include -o $@ $<
-prereq: $(STAGING_DIR_HOST)/bin/mkhash
+$(STAGING_DIR_HOST)/bin/xxd: $(SCRIPT_DIR)/xxdi.pl
+ $(LN) $< $@
+
+prereq: $(STAGING_DIR_HOST)/bin/mkhash $(STAGING_DIR_HOST)/bin/xxd
# Install ldconfig stub
$(eval $(call TestHostCommand,ldconfig-stub,Failed to install stub, \