aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-09-09 12:28:08 -0700
committerChristian Marangi <ansuelsmth@gmail.com>2022-09-11 16:12:24 +0200
commitbe6f0125514db8967a7181420db8ef20990bd93c (patch)
tree4eae8d7aa764048ecea331bcb85027dc3fe5af96 /include/prereq-build.mk
parent4d014a7bd6d8fbfe7dc4cebd6c55d85601231fa4 (diff)
downloadupstream-be6f0125514db8967a7181420db8ef20990bd93c.tar.gz
upstream-be6f0125514db8967a7181420db8ef20990bd93c.tar.bz2
upstream-be6f0125514db8967a7181420db8ef20990bd93c.zip
prereq-build: fix python distutils detection
Debian and by extension Ubuntu packages distutils in a suboptimal way where import distutils works but none of the methods do. This alternative check verifies that distutils is actually usable. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 0a023c2c6f..67993cf7e3 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -188,7 +188,7 @@ $(eval $(call SetupHostCommand,python3,Please install Python >= 3.6, \
$(eval $(call TestHostCommand,python3-distutils, \
Please install the Python3 distutils module, \
- $(STAGING_DIR_HOST)/bin/python3 -c 'import distutils'))
+ $(STAGING_DIR_HOST)/bin/python3 -c 'from distutils import util'))
$(eval $(call SetupHostCommand,file,Please install the 'file' package, \
file --version 2>&1 | grep file))