aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2021-10-09 23:09:46 -1000
committerDaniel Golle <daniel@makrotopia.org>2021-10-10 15:25:58 +0100
commit56ea2bf2eec431ccd3c566190a444ad63db39b65 (patch)
tree7720649c7e74fc295f9b96cb1b8c4f20003859e4 /include/prereq-build.mk
parentb5893a4128ad0c8551c051f563b8e451c3331820 (diff)
downloadupstream-56ea2bf2eec431ccd3c566190a444ad63db39b65.tar.gz
upstream-56ea2bf2eec431ccd3c566190a444ad63db39b65.tar.bz2
upstream-56ea2bf2eec431ccd3c566190a444ad63db39b65.zip
build: prereq detect Python 3.10 for `python3` binary
While the binary `python3.10` is correctly detected by the build system the default `python3` binary is currently not detected if pointing to a Python 3.10 installation. Fix this by extending the grep regex. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index e1993444f7..ce6873cf52 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -162,7 +162,7 @@ $(eval $(call SetupHostCommand,python,Please install Python >= 3.6, \
python3.8 -V 2>&1 | grep 'Python 3', \
python3.7 -V 2>&1 | grep 'Python 3', \
python3.6 -V 2>&1 | grep 'Python 3', \
- python3 -V 2>&1 | grep -E 'Python 3\.[6-9]\.?'))
+ python3 -V 2>&1 | grep -E 'Python 3\.([6-9]|10)\.?'))
$(eval $(call SetupHostCommand,python3,Please install Python >= 3.6, \
python3.10 -V 2>&1 | grep 'Python 3', \
@@ -170,7 +170,7 @@ $(eval $(call SetupHostCommand,python3,Please install Python >= 3.6, \
python3.8 -V 2>&1 | grep 'Python 3', \
python3.7 -V 2>&1 | grep 'Python 3', \
python3.6 -V 2>&1 | grep 'Python 3', \
- python3 -V 2>&1 | grep -E 'Python 3\.[6-9]\.?'))
+ python3 -V 2>&1 | grep -E 'Python 3\.([6-9]|10)\.?'))
$(eval $(call TestHostCommand,python3-distutils, \
Please install the Python3 distutils module, \