aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorChristian 'Ansuel' Marangi <ansuelsmth@gmail.com>2022-06-09 14:13:09 +0200
committerChristian 'Ansuel' Marangi <ansuelsmth@gmail.com>2022-06-09 15:30:33 +0200
commitab1f3a87063b94f485bd582f32a066b80007bac9 (patch)
tree0e8e9bcf38b1fdcf0bef6f17d74b29a7977a7297 /include/prereq-build.mk
parentd55f12cc7925b7d84af80015cbeb0422dd7e0b36 (diff)
downloadupstream-ab1f3a87063b94f485bd582f32a066b80007bac9.tar.gz
upstream-ab1f3a87063b94f485bd582f32a066b80007bac9.tar.bz2
upstream-ab1f3a87063b94f485bd582f32a066b80007bac9.zip
prereq-build: add additional git detection
With some OS (Guix) the git submodule command is wrapped in a script. Current logic parse the git submodule script directly. If it's wrapped the prereq check wrongly fails while 'git submodule --recursive' is actually available. Add an additional check that try to directly use the 'git submodule' command to check if the prereq is satisfied. Fixes: #9986 Reported-by: Attila Lendvai <attila@lendvai.name> Suggested-by: Attila Lendvai <attila@lendvai.name> Signed-off-by: Christian 'Ansuel' Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index e1918f0027..4a8c2b063a 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -177,7 +177,8 @@ $(eval $(call TestHostCommand,python3-distutils, \
$(STAGING_DIR_HOST)/bin/python3 -c 'import distutils'))
$(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
- git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule))
+ git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule, \
+ git submodule --help | grep -- --recursive))
$(eval $(call SetupHostCommand,file,Please install the 'file' package, \
file --version 2>&1 | grep file))