aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2021-09-28 15:03:24 +0200
committerPaul Spooren <mail@aparcar.org>2021-09-28 23:49:02 -1000
commite1c03ca18519f9683f6bfce1795e58d99575d895 (patch)
tree4ad847814f78881d437b57556caee0add2366b5a /include/prereq-build.mk
parent9c3b1d5563923719459493cfdb0b3472735445cd (diff)
downloadupstream-e1c03ca18519f9683f6bfce1795e58d99575d895.tar.gz
upstream-e1c03ca18519f9683f6bfce1795e58d99575d895.tar.bz2
upstream-e1c03ca18519f9683f6bfce1795e58d99575d895.zip
prereq-build: recognize Python 3.10
Fedora 35 contains Python 3.10 as default version. Make use of it. Signed-off-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl> [fix commit subject] Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 922e7c544b..9242407b18 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -157,6 +157,7 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
$(eval $(call CleanupPython2))
$(eval $(call SetupHostCommand,python,Please install Python >= 3.6, \
+ python3.10 -V 2>&1 | grep 'Python 3', \
python3.9 -V 2>&1 | grep 'Python 3', \
python3.8 -V 2>&1 | grep 'Python 3', \
python3.7 -V 2>&1 | grep 'Python 3', \
@@ -164,6 +165,7 @@ $(eval $(call SetupHostCommand,python,Please install Python >= 3.6, \
python3 -V 2>&1 | grep -E 'Python 3\.[6-9]\.?'))
$(eval $(call SetupHostCommand,python3,Please install Python >= 3.6, \
+ python3.10 -V 2>&1 | grep 'Python 3', \
python3.9 -V 2>&1 | grep 'Python 3', \
python3.8 -V 2>&1 | grep 'Python 3', \
python3.7 -V 2>&1 | grep 'Python 3', \