aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorEtienne Champetier <champetier.etienne@gmail.com>2018-04-30 12:55:12 -0700
committerJohn Crispin <john@phrozen.org>2018-05-07 10:31:35 +0200
commitff6e62b288cab103f9dd4200b49ec6dc47375eb8 (patch)
tree5cee24e8f70e0c8aaaeb28001f220c8a3f6cbbbe /include/prereq-build.mk
parentf87dff8f72097bd1f63b4921055060271eae977c (diff)
downloadupstream-ff6e62b288cab103f9dd4200b49ec6dc47375eb8.tar.gz
upstream-ff6e62b288cab103f9dd4200b49ec6dc47375eb8.tar.bz2
upstream-ff6e62b288cab103f9dd4200b49ec6dc47375eb8.zip
build: log time taken by each packages/steps
The idea is to easily get the list of packages taking the most time to build, and see if we can improve them v1: Use SetupHostCommand as recommended by John v2: add space after 'time:', remove useless /usr/bin/time from SetupHostCommand Signed-off-by: Etienne Champetier <champetier.etienne@gmail.com>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 5b9a7e049d..bac5fdc84c 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -138,6 +138,10 @@ $(eval $(call SetupHostCommand,bzip2,Please install 'bzip2', \
$(eval $(call SetupHostCommand,wget,Please install GNU 'wget', \
wget --version | grep GNU))
+$(eval $(call SetupHostCommand,gtime,Please install GNU 'time', \
+ gtime --version 2>&1 | grep GNU, \
+ time --version 2>&1 | grep GNU))
+
$(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
perl --version | grep "perl.*v5"))