aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-28 18:13:54 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-28 18:13:54 +0000
commit8c1649f53c159c7185fdb8e6a1e69fde566bd377 (patch)
tree0b108e68766ddf7035ed0b4ca44bbc023057828f /include/prereq-build.mk
parentf0a180486c758c687646578287913bbfb41b40b8 (diff)
downloadupstream-8c1649f53c159c7185fdb8e6a1e69fde566bd377.tar.gz
upstream-8c1649f53c159c7185fdb8e6a1e69fde566bd377.tar.bz2
upstream-8c1649f53c159c7185fdb8e6a1e69fde566bd377.zip
add PKG_NAME to prereq-build.mk so that failed checks show a proper prefix instead of just ':'
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6747 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index c73b12438f..78a278ead8 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -9,6 +9,8 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/prereq.mk
include $(INCLUDE_DIR)/host.mk
+PKG_NAME:=Build dependency
+
define Require/non-root
[ "$$(shell whoami)" != "root" ]
endef