aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorSven Wegener <sven.wegener@stealer.net>2020-12-27 11:47:45 +0100
committerPaul Spooren <mail@aparcar.org>2021-01-01 10:29:07 -1000
commite9fb9b79f62f7d1224a2c88b5b88969a2442d56a (patch)
tree3cb4805af3e687813f8900ef2713eb77cb84505c /include/package.mk
parent5eaf6d8bead2f1313d2e19ae485fcb008bfc073a (diff)
downloadupstream-e9fb9b79f62f7d1224a2c88b5b88969a2442d56a.tar.gz
upstream-e9fb9b79f62f7d1224a2c88b5b88969a2442d56a.tar.bz2
upstream-e9fb9b79f62f7d1224a2c88b5b88969a2442d56a.zip
build: drop ccache variables from specific targets
With commit 2ca084cc ("build: improve ccache support") these variables are being set globally and we don't need them for specific targets. Signed-off-by: Sven Wegener <sven.wegener@stealer.net>
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk3
1 files changed, 0 insertions, 3 deletions
diff --git a/include/package.mk b/include/package.mk
index 5eb4460db8..24128c53a6 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -175,9 +175,6 @@ define Build/Exports/Default
$(1) : export CONFIG_SITE:=$$(CONFIG_SITE)
$(1) : export PKG_CONFIG_PATH:=$$(PKG_CONFIG_PATH)
$(1) : export PKG_CONFIG_LIBDIR:=$$(PKG_CONFIG_PATH)
- $(if $(CONFIG_CCACHE),$(1) : export CCACHE_BASEDIR:=$(TOPDIR))
- $(if $(CONFIG_CCACHE),$(1) : export CCACHE_DIR:=$(if $(call qstrip,$(CONFIG_CCACHE_DIR)),$(call qstrip,$(CONFIG_CCACHE_DIR)),$(TOPDIR)/.ccache))
- $(if $(CONFIG_CCACHE),$(1) : export CCACHE_COMPILERCHECK:=%compiler% -dumpmachine; %compiler% -dumpversion)
endef
Build/Exports=$(Build/Exports/Default)