aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-18 14:27:04 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-18 23:57:08 +0100
commit9228d1c066cf3a2cd01288bed3646e53638705b6 (patch)
treee5e9af619fd75d10b58f4088191ca2adec64549c /include/package.mk
parent6cf067d084cc551c721e98b6d6c6403a63e521d5 (diff)
downloadupstream-9228d1c066cf3a2cd01288bed3646e53638705b6.tar.gz
upstream-9228d1c066cf3a2cd01288bed3646e53638705b6.tar.bz2
upstream-9228d1c066cf3a2cd01288bed3646e53638705b6.zip
build: introduce extra targets that contain only proper dependencies
This can be used to check if targets like prepare or compile are up to date Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk11
1 files changed, 6 insertions, 5 deletions
diff --git a/include/package.mk b/include/package.mk
index 62e538c594..37cea1448d 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -204,13 +204,13 @@ define Build/CoreTargets
touch $$@
ifdef Build/InstallDev
- compile: $(STAMP_INSTALLED)
+ .compile: $(STAMP_INSTALLED)
endif
- prepare: $(STAMP_PREPARED)
- configure: $(STAMP_CONFIGURED)
- dist: $(STAMP_CONFIGURED)
- distcheck: $(STAMP_CONFIGURED)
+ .prepare: $(STAMP_PREPARED)
+ .configure: $(STAMP_CONFIGURED)
+ .dist: $(STAMP_CONFIGURED)
+ .distcheck: $(STAMP_CONFIGURED)
endef
define Build/DefaultTargets
@@ -289,6 +289,7 @@ $(PACKAGE_DIR):
mkdir -p $@
compile: prepare-package-install
+.install: .compile
install: compile
clean: FORCE