aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-06-09 15:38:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-06-09 15:38:45 +0000
commit4c665e6ca4ce7044fbaf4e6a772b021c012f760c (patch)
tree2c5c0574cfda7d10c196399fd2791f5b57004f7b /include/package.mk
parent21e09858f13eb471582ca09f1ce306a004203fb2 (diff)
downloadupstream-4c665e6ca4ce7044fbaf4e6a772b021c012f760c.tar.gz
upstream-4c665e6ca4ce7044fbaf4e6a772b021c012f760c.tar.bz2
upstream-4c665e6ca4ce7044fbaf4e6a772b021c012f760c.zip
large improvement for parallel builds. works without V=99 now and without warnings. tested with -j on an 2x dual core opteron machine
SVN-Revision: 11414
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package.mk b/include/package.mk
index 74ad478747..da8de5cccf 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -83,7 +83,7 @@ define Build/DefaultTargets
touch $$@
$(STAMP_INSTALLED): $(STAMP_BUILT)
- $(SUBMAKE) clean-staging
+ $(SUBMAKE) -j1 clean-staging
rm -rf $(TMP_DIR)/stage-$(PKG_NAME)
mkdir -p $(TMP_DIR)/stage-$(PKG_NAME)/host $(STAGING_DIR)/packages $(STAGING_DIR_HOST)/packages
$(call Build/InstallDev,$(TMP_DIR)/stage-$(PKG_NAME),$(TMP_DIR)/stage-$(PKG_NAME)/host)