aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-03 06:16:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-03 06:16:08 +0000
commit414e3ef71af42ec5a4c18ff0be41f7b794ab28e7 (patch)
treeeed2fdcff73a7374bac56a637ae02b5362877ec7 /include/package.mk
parent304696e31df4478708f59f2c81433339e4634e7f (diff)
downloadupstream-414e3ef71af42ec5a4c18ff0be41f7b794ab28e7.tar.gz
upstream-414e3ef71af42ec5a4c18ff0be41f7b794ab28e7.tar.bz2
upstream-414e3ef71af42ec5a4c18ff0be41f7b794ab28e7.zip
Add quilt integration for packages
make package/<package>-prepare QUILT=1 will apply all patches using quilt Autorebuild will be disabled, so that you can edit all patches in the build dir. When you're done editing patches and everything works, you can call: make package/<package>-refresh That will copy the updated patches from quilt into package/<package>/patches, and remove all old patches. Before the patches are overwritten, the correct order of the patches is verified ('cat series' is compared against 'sort series'). git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7471 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk9
1 files changed, 6 insertions, 3 deletions
diff --git a/include/package.mk b/include/package.mk
index 3e2944fbdc..daff3ed0d6 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -14,13 +14,16 @@ include $(INCLUDE_DIR)/prereq.mk
include $(INCLUDE_DIR)/host.mk
include $(INCLUDE_DIR)/unpack.mk
include $(INCLUDE_DIR)/depends.mk
-include $(INCLUDE_DIR)/package-defaults.mk
-include $(INCLUDE_DIR)/package-dumpinfo.mk
-include $(INCLUDE_DIR)/package-ipkg.mk
STAMP_PREPARED:=$(PKG_BUILD_DIR)/.prepared$(if $(DUMP),,_$(shell find ${CURDIR} $(PKG_FILE_DEPEND) $(DEP_FINDPARAMS) | md5s))
STAMP_CONFIGURED:=$(PKG_BUILD_DIR)/.configured
STAMP_BUILT:=$(PKG_BUILD_DIR)/.built
+
+include $(INCLUDE_DIR)/quilt.mk
+include $(INCLUDE_DIR)/package-defaults.mk
+include $(INCLUDE_DIR)/package-dumpinfo.mk
+include $(INCLUDE_DIR)/package-ipkg.mk
+
export CONFIG_SITE:=$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)
ifneq ($(CONFIG_AUTOREBUILD),)