aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2007-10-08 19:49:11 +0000
committerJohn Crispin <blogic@openwrt.org>2007-10-08 19:49:11 +0000
commit0c85c497e4735a8c83e799f7f853be76f0809d43 (patch)
treeddfa22f99be2b9a7b6856485de121e6dc97e60ed /include/package.mk
parent0f0020cac022f0dcf0462f41125dad2a4e0675ff (diff)
downloadupstream-0c85c497e4735a8c83e799f7f853be76f0809d43.tar.gz
upstream-0c85c497e4735a8c83e799f7f853be76f0809d43.tar.bz2
upstream-0c85c497e4735a8c83e799f7f853be76f0809d43.zip
changed pkg_install_files so one can specify the folder to install from
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9192 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package.mk b/include/package.mk
index 6307a1f47c..d90bec8872 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -122,7 +122,7 @@ define libtool_fixup_libdir
endef
define pkg_install_files
- $(foreach install_file,$(2),$(INSTALL_DIR) $(1)/`dirname $(install_file)`; $(CP) $(PKG_INSTALL_DIR)/$(install_file) $(1)/`dirname $(install_file)`;)
+ $(foreach install_file,$(3),$(INSTALL_DIR) $(2)/`dirname $(install_file)`; $(CP) $(1)/$(install_file) $(2)/`dirname $(install_file)`;)
endef
define Build/Prepare