aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-20 01:35:13 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-20 01:35:13 +0000
commitd13e8228b160a6f66b6a5b174e82d4fc9c1b6567 (patch)
tree1635390305bb74b11deb53cd229cca71d39b6e5e /include/package.mk
parent6909e7767259ea57023d24c3d36415dcc0f2f96f (diff)
downloadupstream-d13e8228b160a6f66b6a5b174e82d4fc9c1b6567.tar.gz
upstream-d13e8228b160a6f66b6a5b174e82d4fc9c1b6567.tar.bz2
upstream-d13e8228b160a6f66b6a5b174e82d4fc9c1b6567.zip
clean up package rebuild messages
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6134 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk9
1 files changed, 2 insertions, 7 deletions
diff --git a/include/package.mk b/include/package.mk
index 616cc975f4..dd70128c8f 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -20,9 +20,8 @@ export CONFIG_SITE:=$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)
define Build/DefaultTargets
ifeq ($(DUMP),)
ifeq ($(CONFIG_AUTOREBUILD),y)
- _INFO:=
ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) . $(PKG_FILE_DEPEND)),$(PKG_BUILD_DIR))
- _INFO+=$(subst $(TOPDIR)/,,$(PKG_BUILD_DIR))
+ $$(info Forcing package rebuild)
$(PKG_BUILD_DIR)/.prepared: package-clean
endif
endif
@@ -264,12 +263,8 @@ define BuildPackage
ifneq ($(MAKECMDGOALS),prereq)
ifneq ($(DUMP),1)
ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install '$$(IPKG_$(1))' '$(PKG_BUILD_DIR)'),$$(IPKG_$(1)))
- _INFO+=$(subst $(TOPDIR)/,,$$(IPKG_$(1)))
$(PKG_BUILD_DIR)/.built: package-rebuild
- endif
-
- ifneq ($$(_INFO),)
- $$(info Rebuilding $$(_INFO))
+ $$(info Rebuilding $(subst $(TOPDIR)/,,$$(IPKG_$(1))))
endif
endif
endif