aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-28 01:23:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-28 01:23:56 +0000
commit499485004b52b5960c950922fb1dedcedd0923fa (patch)
tree78a221d6379016a74f33e2257e609a7194db7f27 /include/package.mk
parentd2c8e2185055230a43bafaa28017dc11ee40d927 (diff)
downloadupstream-499485004b52b5960c950922fb1dedcedd0923fa.tar.gz
upstream-499485004b52b5960c950922fb1dedcedd0923fa.tar.bz2
upstream-499485004b52b5960c950922fb1dedcedd0923fa.zip
some minor fixes, cleanups, package build abstraction
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9051 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk11
1 files changed, 9 insertions, 2 deletions
diff --git a/include/package.mk b/include/package.mk
index 43d0663f60..9090455658 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -97,8 +97,15 @@ endif
$(call shexport,Package/$(1)/description)
$(call shexport,Package/$(1)/config)
- $(Dumpinfo)
- $(BuildIPKG)
+ $(if $(DUMP), \
+ $(Dumpinfo), \
+ $(foreach target, \
+ $(if $(Package/$(1)/targets),$(Package/$(1)/targets), \
+ $(if $(PKG_TARGETS),$(PKG_TARGETS), ipkg ) \
+ ), $(BuildTarget/$(target)) \
+ ) \
+ )
+ $(if $(DUMP),,$(call Build/DefaultTargets,$(1)))
endef
# prevent libtool from setting rpath when linking