aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-19 06:38:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-19 06:38:06 +0000
commit2d6750fb1d4b919df370f307b768f2a36c64718d (patch)
treee544f75ccc69bc0118212d1056e6372f26495465 /include/package.mk
parentcbe69ab035184130afbf829e3459967d2b40dc1e (diff)
downloadupstream-2d6750fb1d4b919df370f307b768f2a36c64718d.tar.gz
upstream-2d6750fb1d4b919df370f307b768f2a36c64718d.tar.bz2
upstream-2d6750fb1d4b919df370f307b768f2a36c64718d.zip
fix unnecessary kernel package recompile
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5227 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk22
1 files changed, 12 insertions, 10 deletions
diff --git a/include/package.mk b/include/package.mk
index 05b4ffd2dc..b4f16e2d3a 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -256,16 +256,18 @@ define BuildPackage
$$(eval $$(call Build/DefaultTargets,$(1)))
- ifneq ($$(CONFIG_PACKAGE_$(1)),)
- ifneq ($(MAKECMDGOALS),prereq)
- ifneq ($(DUMP),1)
- ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install '$$(IPKG_$(1))' '$(PKG_BUILD_DIR)'),$$(IPKG_$(1)))
- _INFO+=$(subst $(TOPDIR)/,,$$(IPKG_$(1)))
- $(PKG_BUILD_DIR)/.built: package-rebuild
- endif
-
- ifneq ($$(_INFO),)
- $$(info Rebuilding $$(_INFO))
+ ifdef Package/$(1)/install
+ ifneq ($$(CONFIG_PACKAGE_$(1)),)
+ ifneq ($(MAKECMDGOALS),prereq)
+ ifneq ($(DUMP),1)
+ ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install '$$(IPKG_$(1))' '$(PKG_BUILD_DIR)'),$$(IPKG_$(1)))
+ _INFO+=$(subst $(TOPDIR)/,,$$(IPKG_$(1)))
+ $(PKG_BUILD_DIR)/.built: package-rebuild
+ endif
+
+ ifneq ($$(_INFO),)
+ $$(info Rebuilding $$(_INFO))
+ endif
endif
endif
endif