aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2021-06-14 14:58:37 +0200
committerJo-Philipp Wich <jo@mein.io>2021-07-11 16:09:30 +0200
commit47f617ef8d44e4d7428ff3e0b42acb4a75f5cd37 (patch)
tree0c77381969347440193feba1b1175b7e3a9d37c5 /include/package-ipkg.mk
parentfebf6db0d02c1bdadd4db621a0070b80eb94b7fb (diff)
downloadupstream-47f617ef8d44e4d7428ff3e0b42acb4a75f5cd37.tar.gz
upstream-47f617ef8d44e4d7428ff3e0b42acb4a75f5cd37.tar.bz2
upstream-47f617ef8d44e4d7428ff3e0b42acb4a75f5cd37.zip
build: prepend ABI suffixes with a dash if package name ends with digit
Ensure that ABI suffixes are separated with a dash from the package name if the name happens to end with a digit. This implementation detail got lost during the recent refactoring of the ABI_VERSION handling in buildroot. Ref: https://github.com/openwrt/packages/pull/14237#issuecomment-860473585 Fixes: c921650382 ("build: drop ABI version from metadata") Signed-off-by: Jo-Philipp Wich <jo@mein.io> (cherry picked from commit f6a03bff5bccdbf9165087bccbb35095903d05c6)
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index c2017cd220..e972b7de0b 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -99,7 +99,7 @@ _endef=endef
ifeq ($(DUMP),)
define BuildTarget/ipkg
- ABIV_$(1):=$(if $(filter-out kmod-%,$(1)),$(ABI_VERSION))
+ ABIV_$(1):=$(call FormatABISuffix,$(1),$(ABI_VERSION))
PDIR_$(1):=$(call FeedPackageDir,$(1))
IPKG_$(1):=$$(PDIR_$(1))/$(1)$$(ABIV_$(1))_$(VERSION)_$(PKGARCH).ipk
IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg-$(PKGARCH)/$(1)