aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-08-06 18:18:47 +0000
committerJohn Crispin <blogic@openwrt.org>2014-08-06 18:18:47 +0000
commit63cb54edd5e55ad7f89eea303deb34a2e38cf874 (patch)
treeb3367ee4159104d807163e570c66d52f131db791 /include/package-ipkg.mk
parentae669a075f4c0d41f62fc0d73fa37cea9f64ea10 (diff)
downloadupstream-63cb54edd5e55ad7f89eea303deb34a2e38cf874.tar.gz
upstream-63cb54edd5e55ad7f89eea303deb34a2e38cf874.tar.bz2
upstream-63cb54edd5e55ad7f89eea303deb34a2e38cf874.zip
build: introduce per feed repository support
This changeset implements a new menuconfig option to generate separate repositories for each enabled package feed instead of one monolithic one. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> Backport of r42002 git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@42016 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk10
1 files changed, 7 insertions, 3 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 9783a63254..be47526467 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -5,6 +5,8 @@
# See /LICENSE for more information.
#
+include $(INCLUDE_DIR)/feeds.mk
+
# invoke ipkg-build with some default options
IPKG_BUILD:= \
ipkg-build -c -o 0 -g 0
@@ -74,7 +76,8 @@ endif
ifeq ($(DUMP),)
define BuildTarget/ipkg
- IPKG_$(1):=$(PACKAGE_DIR)/$(1)_$(VERSION)_$(PKGARCH).ipk
+ PDIR_$(1):=$(call FeedPackageDir,$(1))
+ IPKG_$(1):=$$(PDIR_$(1))/$(1)_$(VERSION)_$(PKGARCH).ipk
IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg-$(PKGARCH)/$(1)
KEEP_$(1):=$(strip $(call Package/$(1)/conffiles))
@@ -187,11 +190,12 @@ ifeq ($(DUMP),)
)
endif
- $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
+ $(INSTALL_DIR) $$(PDIR_$(1))
+ $(IPKG_BUILD) $$(IDIR_$(1)) $$(PDIR_$(1))
@[ -f $$(IPKG_$(1)) ]
$(1)-clean:
- rm -f $(PACKAGE_DIR)/$(1)_*
+ rm -f $$(PDIR_$(1))/$(1)_*
clean: $(1)-clean