aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2017-03-05 16:19:46 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2017-05-02 22:10:51 +0800
commit73bc636aba3ec0c6381605d1f11088955101975a (patch)
tree168b4a4279d69092ec2837ea65d5a5726cd3b13b /include/package-ipkg.mk
parentdac629f71093715ea002c7949a9888188e58984e (diff)
downloadupstream-73bc636aba3ec0c6381605d1f11088955101975a.tar.gz
upstream-73bc636aba3ec0c6381605d1f11088955101975a.tar.bz2
upstream-73bc636aba3ec0c6381605d1f11088955101975a.zip
build: ipkg: new field Alternatives
It's a list of specs of the following form seprated by commas to describe alternatives provided by this package <prio>:<path>:<altpath> <path> will be a symbolic link to <altpath> of the highest <prio> Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 620be991b3..bf508fb493 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -159,6 +159,7 @@ Version: $(VERSION)
$$(call addfield,Depends,$$(Package/$(1)/DEPENDS)
)$$(call addfield,Conflicts,$$(call mergelist,$(CONFLICTS))
)$$(call addfield,Provides,$$(call mergelist,$(PROVIDES))
+)$$(call addfield,Alternatives,$$(call mergelist,$(ALTERNATIVES))
)$$(call addfield,Source,$(SOURCE)
)$$(call addfield,License,$$(PKG_LICENSE)
)$$(call addfield,LicenseFiles,$$(PKG_LICENSE_FILES)