aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2017-10-31 21:29:50 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-11-25 20:02:04 +0100
commit2cb75cd8b9d451bde0cfffce80fa67d58944c44b (patch)
treed6d164cbdad1411c62a318dd8af08e17188386f5 /include/package-ipkg.mk
parent40868e3bb6d81510425673d693a8d3abcc4193f7 (diff)
downloadupstream-2cb75cd8b9d451bde0cfffce80fa67d58944c44b.tar.gz
upstream-2cb75cd8b9d451bde0cfffce80fa67d58944c44b.tar.bz2
upstream-2cb75cd8b9d451bde0cfffce80fa67d58944c44b.zip
build: allow defining license information per binary package
At the moment, license information can only be specified on a "per source package" level while other metadata fields (e.g. maintainer) can be given for each binary package. Apply the same logic for license fields as well. This can be used e.g. in cases where a library is distributed under some license while related tools are distributed under a different one. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index bf508fb493..9e2717e788 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -161,8 +161,8 @@ $$(call addfield,Depends,$$(Package/$(1)/DEPENDS)
)$$(call addfield,Provides,$$(call mergelist,$(PROVIDES))
)$$(call addfield,Alternatives,$$(call mergelist,$(ALTERNATIVES))
)$$(call addfield,Source,$(SOURCE)
-)$$(call addfield,License,$$(PKG_LICENSE)
-)$$(call addfield,LicenseFiles,$$(PKG_LICENSE_FILES)
+)$$(call addfield,License,$(LICENSE)
+)$$(call addfield,LicenseFiles,$(LICENSE_FILES)
)$$(call addfield,Section,$(SECTION)
)$$(call addfield,Require-User,$(USERID)
)$(if $(filter hold,$(PKG_FLAGS)),Status: unknown hold not-installed