aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-dumpinfo.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-16 03:02:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-16 03:02:31 +0000
commit97276e7bf0218aed134c13c5db8f410a1ceebdea (patch)
tree392f9df044ecb4fd824e3915ec78f39a4e54746b /include/package-dumpinfo.mk
parent0241b19768532635b521bf35f7746d4fc37ae91e (diff)
downloadupstream-97276e7bf0218aed134c13c5db8f410a1ceebdea.tar.gz
upstream-97276e7bf0218aed134c13c5db8f410a1ceebdea.tar.bz2
upstream-97276e7bf0218aed134c13c5db8f410a1ceebdea.zip
Add an 'Image Configuration' menu to menuconfig
Packages can export a list of config options with labels and data types through the metadata. The selected config values will be exported to the target filesystem in /etc/uci-defaults and applied on the first boot. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6572 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-dumpinfo.mk')
-rw-r--r--include/package-dumpinfo.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/include/package-dumpinfo.mk b/include/package-dumpinfo.mk
index 2d52f23475..e6a462863c 100644
--- a/include/package-dumpinfo.mk
+++ b/include/package-dumpinfo.mk
@@ -6,7 +6,11 @@
#
ifneq ($(DUMP),)
-define Dumpinfo
+define Config
+ preconfig_$$(1) += echo "Preconfig: $(1)"; echo "Preconfig-Type: $(2)"; echo "Preconfig-Default: $(3)"; echo "Preconfig-Label: $(4)";
+endef
+
+define Dumpinfo
dumpinfo: dumpinfo-$(1)
dumpinfo-$(1): FORCE
@echo "Package: $(1)" ; \
@@ -28,5 +32,6 @@ define Dumpinfo
$(if $(URL),echo;echo "$(URL)";) \
echo "@@" ; \
$$(if $$(Package/$(1)/config),echo "Config: "; getvar $(call shvar,Package/$(1)/config); echo "@@")
+ $(if $$(preconfig_$(1)),@$$(preconfig_$(1)) echo "")
endef
endif