aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-defaults.mk
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2022-08-24 22:32:13 -0400
committerHauke Mehrtens <hauke@hauke-m.de>2023-03-13 22:53:41 +0100
commit129be247a6a0cb11132691bdf27104f48ab08530 (patch)
tree911af3d8932e94667d4b5396509d661e9ba52f56 /include/package-defaults.mk
parenta7a3de5edb142c7cefdb6e810cc07a6222f7541d (diff)
downloadupstream-129be247a6a0cb11132691bdf27104f48ab08530.tar.gz
upstream-129be247a6a0cb11132691bdf27104f48ab08530.tar.bz2
upstream-129be247a6a0cb11132691bdf27104f48ab08530.zip
build: disable automake dependency tracking
Recent versions of Automake have changed dependency tracking significantly (reference commit below) causing breakage in some package builds when using newer Automake with packages that need autoreconf that were bootstrapped with an old version of Automake. Those changes cause a great inconsistency between packages over time where some packages may or may not use this feature, and may or may not update the .ac and .am files to work with the new methods. This problem might exist in many packages where autoreconf is not currently required, but would cause build failure if autoreconf is used. Fortunately, this feature is practically useless for the purposes of Openwrt and the average developer, so we can disable it. GNU Automake manual states in part: "Because dependencies are only computed as a side-effect of compilation... no dependency information exists the first time a package is built... dependency tracking is completely useless for one-time builds..." A nice side-effect is that build times are slightly faster. Ref: 6a675ef17edf7109da189f5ae70e2dc6b7665896 (automake.git) Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'include/package-defaults.mk')
-rw-r--r--include/package-defaults.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/package-defaults.mk b/include/package-defaults.mk
index 72f88b9bbb..2cff26b531 100644
--- a/include/package-defaults.mk
+++ b/include/package-defaults.mk
@@ -80,6 +80,7 @@ CONFIGURE_ARGS = \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
+ --disable-dependency-tracking \
--program-prefix="" \
--program-suffix="" \
--prefix=$(CONFIGURE_PREFIX) \