aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-bin.mk
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2021-11-03 15:51:32 -0300
committerHauke Mehrtens <hauke@hauke-m.de>2021-11-15 00:38:46 +0100
commit91a5d69ea40196044e7456d72095afb655b0c5aa (patch)
tree41b7cafa79e87ebe2b436400cd1ca14a2958ce00 /include/package-bin.mk
parent63ce6fcd2093a3503044d51f7a025bf8b0a8260f (diff)
downloadupstream-91a5d69ea40196044e7456d72095afb655b0c5aa.tar.gz
upstream-91a5d69ea40196044e7456d72095afb655b0c5aa.tar.bz2
upstream-91a5d69ea40196044e7456d72095afb655b0c5aa.zip
build: allow package to be built for all variants
This allows a package to be rebuilt for all different VARIANTs. To do so, set VARIANT=*. The wpa-cli package is not getting built after changes made by 19aae94 [build: avoid rebuilds of unset VARIANT packages], because wpa-cli is only built when compiling a variant that includes supplicant support, and the first selected variant may not build it. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'include/package-bin.mk')
-rw-r--r--include/package-bin.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-bin.mk b/include/package-bin.mk
index 77e603e420..4ca49218e9 100644
--- a/include/package-bin.mk
+++ b/include/package-bin.mk
@@ -4,7 +4,7 @@
ifeq ($(DUMP),)
define BuildTarget/bin
- TARGET_VARIANT=$(if $(ALL_VARIANTS),$(if $(VARIANT),$(VARIANT),$(firstword $(ALL_VARIANTS))))
+ TARGET_VARIANT=$(if $(ALL_VARIANTS),$(if $(VARIANT),$(filter-out *,$(VARIANT)),$(firstword $(ALL_VARIANTS))))
ifeq ($(if $(TARGET_VARIANT),$(BUILD_VARIANT)),$(TARGET_VARIANT))
ifdef Package/$(1)/install
ifneq ($(CONFIG_PACKAGE_$(1))$(DEVELOPER),)