aboutsummaryrefslogtreecommitdiffstats
path: root/include/nls.mk
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2022-06-05 20:02:08 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-07-15 15:21:44 +0200
commit92f0b7d4d25c8493270051298a4073f5b630bda3 (patch)
treeed420b4174d9b11de4f8068696697983ec67496b /include/nls.mk
parent2747a94f0977b36c4c29cc4596879b9127cfaf5f (diff)
downloadupstream-92f0b7d4d25c8493270051298a4073f5b630bda3.tar.gz
upstream-92f0b7d4d25c8493270051298a4073f5b630bda3.tar.bz2
upstream-92f0b7d4d25c8493270051298a4073f5b630bda3.zip
nls.mk: clean up INTL flags
gettext (libintl-stub) was removed in commit [1], so the libintl-stub lib and include directories aren't existing anymore. This commit cleans up the INTL flags for the BUILD_NLS=n case. [1] e6f569406ffe1d9e35b9b9ea36f38cdd5837728d Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net> Reviewed-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'include/nls.mk')
-rw-r--r--include/nls.mk14
1 files changed, 10 insertions, 4 deletions
diff --git a/include/nls.mk b/include/nls.mk
index 163e480932..665ccb565d 100644
--- a/include/nls.mk
+++ b/include/nls.mk
@@ -15,7 +15,7 @@ else
ICONV_PREFIX:=$(STAGING_DIR)/usr/lib/libiconv-stub
ICONV_FULL:=
- INTL_PREFIX:=$(STAGING_DIR)/usr/lib/libintl-stub
+ INTL_PREFIX:=
INTL_FULL:=
endif
@@ -28,9 +28,15 @@ ICONV_CPPFLAGS:=-I$(ICONV_PREFIX)/include
ICONV_LDFLAGS:=-L$(ICONV_PREFIX)/lib -Wl,-rpath-link=$(ICONV_PREFIX)/lib
INTL_DEPENDS:=+BUILD_NLS:libintl-full
-INTL_CFLAGS:=-I$(INTL_PREFIX)/include
-INTL_CPPFLAGS:=-I$(INTL_PREFIX)/include
-INTL_LDFLAGS:=-L$(INTL_PREFIX)/lib -Wl,-rpath-link=$(INTL_PREFIX)/lib
+ifeq ($(CONFIG_BUILD_NLS),y)
+ INTL_CFLAGS:=-I$(INTL_PREFIX)/include
+ INTL_CPPFLAGS:=-I$(INTL_PREFIX)/include
+ INTL_LDFLAGS:=-L$(INTL_PREFIX)/lib -Wl,-rpath-link=$(INTL_PREFIX)/lib
+else
+ INTL_CFLAGS:=
+ INTL_CPPFLAGS:=
+ INTL_LDFLAGS:=
+endif
TARGET_CFLAGS += $(ICONV_CFLAGS) $(INTL_CFLAGS)
TARGET_CPPFLAGS += $(ICONV_CPPFLAGS) $(INTL_CPPFLAGS)