aboutsummaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-11-27 23:37:19 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-12-15 14:28:50 +0100
commitf72f793c9e61b8a55eb8c162b71a6d8860906a4e (patch)
treeae8097906fc83de5d88af88e482fad46cef7a6b3 /include/netfilter.mk
parent89806545cc1711f4e33c1c2ac5265aec4afe8078 (diff)
downloadupstream-f72f793c9e61b8a55eb8c162b71a6d8860906a4e.tar.gz
upstream-f72f793c9e61b8a55eb8c162b71a6d8860906a4e.tar.bz2
upstream-f72f793c9e61b8a55eb8c162b71a6d8860906a4e.zip
kernel: netfilter: Add nf_conncount.ko
Some kernel modules from kmod-ipt-conntrack-extra depend on nf_conncount.ko, which was added in kernel 4.16, add it to the kmod. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index b73cc794b6..2d232b5f5c 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -80,6 +80,7 @@ $(eval $(call nf_add,IPT_CONNTRACK,CONFIG_NETFILTER_XT_MATCH_CONNTRACK, $(P_XT)x
$(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_NETFILTER_XT_MATCH_CONNBYTES, $(P_XT)xt_connbytes))
$(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_NETFILTER_XT_MATCH_CONNLIMIT, $(P_XT)xt_connlimit))
+$(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_NETFILTER_CONNCOUNT, $(P_XT)nf_conncount))
$(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_NETFILTER_XT_CONNMARK, $(P_XT)xt_connmark))
$(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_NETFILTER_XT_MATCH_HELPER, $(P_XT)xt_helper))
$(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_NETFILTER_XT_MATCH_RECENT, $(P_XT)xt_recent))