aboutsummaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-02-19 01:36:47 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-02-19 01:36:47 +0000
commit7fc4138b4dd29cbd3c0eb346276987a7dc8e9eaf (patch)
treeef3964ef61310a708e2efc9f9a7fc6ba4f1bd6b5 /include/netfilter.mk
parent2ba4b4f580dacb90ed2434c25bfb37864816e4f2 (diff)
downloadupstream-7fc4138b4dd29cbd3c0eb346276987a7dc8e9eaf.tar.gz
upstream-7fc4138b4dd29cbd3c0eb346276987a7dc8e9eaf.tar.bz2
upstream-7fc4138b4dd29cbd3c0eb346276987a7dc8e9eaf.zip
[generic-2.4] netfilter: add support for raw table and NOTRACK target (#5504)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19721 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 9eeee4f6e1..c8347936d4 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -91,6 +91,7 @@ $(eval $(if $(NF_KMOD),$(call nf_add,IPT_CONNTRACK,CONFIG_NF_CONNTRACK_IPV4, $(P
$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_IP_NF_MATCH_STATE, $(P_V4)ipt_state))
$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_NETFILTER_XT_MATCH_STATE, $(P_XT)xt_state))
$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_IP_NF_RAW, $(P_V4)iptable_raw))
+$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_IP_NF_TARGET_NOTRACK, $(P_V4)ipt_NOTRACK))
$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_NETFILTER_XT_TARGET_NOTRACK, $(P_XT)xt_NOTRACK))