aboutsummaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-10-07 17:17:04 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-10-07 17:17:04 +0000
commit6958bdb20aad8a3d1dda124747529f79eec4ce7f (patch)
treeb157c9ce75f7e761524af78499e7fa6b51287758 /include/netfilter.mk
parent8853b87bdaec3392e45ec2964f9248334638edce (diff)
downloadupstream-6958bdb20aad8a3d1dda124747529f79eec4ce7f.tar.gz
upstream-6958bdb20aad8a3d1dda124747529f79eec4ce7f.tar.bz2
upstream-6958bdb20aad8a3d1dda124747529f79eec4ce7f.zip
add TARPIT support to netfilter/iptables
* netfilter: add the xt_TARPIT target module required by xt_CHAOS * include/netfilter.mk: reorder, xt_CHAOS depends on xt_TARPIT and xt_DELUDE * iptables: add libipt_TARPIT to the kmod-ipt-extra package, bump release number * original patchset can be found [http://tinyurl.com/2mjk2kx here] git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9178 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 9ed736aea7..bb59bf03d8 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -1,4 +1,4 @@
-#
+#
# Copyright (C) 2006 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
@@ -60,8 +60,9 @@ $(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_MATCH_PORTSCAN, $(P_XT)xt_por
#$(eval $(call nf_add,IPT_EXTRA,CONFIG_IP_NF_MATCH_QUOTA, $(P_V4)ipt_quota))
$(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_MATCH_QUOTA, $(P_XT)xt_quota))
-$(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_TARGET_CHAOS, $(P_XT)xt_CHAOS))
+$(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_TARGET_TARPIT, $(P_XT)xt_TARPIT))
$(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_TARGET_DELUDE, $(P_XT)xt_DELUDE))
+$(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_TARGET_CHAOS, $(P_XT)xt_CHAOS))
$(eval $(call nf_add,IPT_EXTRA,CONFIG_IP_NF_TARGET_LOG, $(P_V4)ipt_LOG))
$(eval $(call nf_add,IPT_EXTRA,CONFIG_IP_NF_TARGET_REJECT, $(P_V4)ipt_REJECT))
#$(eval $(call nf_add,IPT_EXTRA,CONFIG_IP_NF_TARGET_ROUTE, $(P_V4)ipt_ROUTE))