aboutsummaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-22 01:23:44 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-22 01:23:44 +0000
commit276ec5d114bf6e334d862c7c903d955f320a4bc7 (patch)
tree596862fba0c025564c714bd8618f45a21569c4a3 /include/netfilter.mk
parent3aad35e9f792d6296e6f79303dcc660d0df7590b (diff)
downloadupstream-276ec5d114bf6e334d862c7c903d955f320a4bc7.tar.gz
upstream-276ec5d114bf6e334d862c7c903d955f320a4bc7.tar.bz2
upstream-276ec5d114bf6e334d862c7c903d955f320a4bc7.zip
add missing config checks for the netfilter connmark target (fixes #1186)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6172 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 1d8f4d880e..030436e46e 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -17,6 +17,8 @@ IPT_CONNTRACK-$(CONFIG_IP_NF_TARGET_CONNMARK) += $(P_V4)ipt_CONNMARK
IPT_CONNTRACK-$(CONFIG_IP_NF_MATCH_CONNTRACK) += $(P_V4)ipt_conntrack
IPT_CONNTRACK-$(CONFIG_IP_NF_MATCH_HELPER) += $(P_V4)ipt_helper
IPT_CONNTRACK-$(CONFIG_IP_NF_MATCH_STATE) += $(P_V4)ipt_state
+IPT_CONNTRACK-$(CONFIG_NETFILTER_XT_MATCH_CONNMARK) += $(P_XT)ipt_connmark
+IPT_CONNTRACK-$(CONFIG_NETFILTER_XT_TARGET_CONNMARK) += $(P_XT)ipt_CONNMARK
IPT_CONNTRACK-$(CONFIG_NETFILTER_XT_MATCH_CONNTRACK) += $(P_XT)xt_conntrack
IPT_CONNTRACK-$(CONFIG_NETFILTER_XT_MATCH_HELPER) += $(P_XT)xt_helper
IPT_CONNTRACK-$(CONFIG_NETFILTER_XT_MATCH_STATE) += $(P_XT)xt_state