aboutsummaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-25 09:55:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-25 09:55:07 +0000
commit1b9defcfda8b2b80fa502ead79d7fba1ab63a442 (patch)
tree5ecef9df312185665ef62e10728da251150d2649 /include/netfilter.mk
parentc16aa532fe7bc1496fb3af1813c9b34248845166 (diff)
downloadupstream-1b9defcfda8b2b80fa502ead79d7fba1ab63a442.tar.gz
upstream-1b9defcfda8b2b80fa502ead79d7fba1ab63a442.tar.bz2
upstream-1b9defcfda8b2b80fa502ead79d7fba1ab63a442.zip
add nat module fix from #1772
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7727 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 1c9c752f70..2ff30c2442 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -103,6 +103,7 @@ IPT_IPSET-$(CONFIG_IP_NF_TARGET_SET) += $(P_V4)ipt_SET
IPT_NAT-m :=
ifneq ($(NF_KMOD),1)
IPT_NAT-$(CONFIG_IP_NF_NAT) += $(P_V4)ipt_SNAT $(P_V4)ipt_DNAT
+ IPT_NAT-$(CONFIG_NF_NAT) += $(P_V4)ipt_SNAT $(P_V4)ipt_DNAT
endif
IPT_NAT-$(CONFIG_IP_NF_TARGET_MASQUERADE) += $(P_V4)ipt_MASQUERADE
IPT_NAT-$(CONFIG_IP_NF_TARGET_MIRROR) += $(P_V4)ipt_MIRROR