aboutsummaryrefslogtreecommitdiffstats
path: root/include/meson.mk
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-01-30 18:52:15 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2022-02-07 00:03:27 +0100
commit4c42e2d9dda739baa6a144cdb009aef1a33824a0 (patch)
treecd46f9be2d4157eeef7ca5cf4fe056ea657f3a82 /include/meson.mk
parent8cfce165a7e3605c22b045cdc1f745b4d6b49fb9 (diff)
downloadupstream-4c42e2d9dda739baa6a144cdb009aef1a33824a0.tar.gz
upstream-4c42e2d9dda739baa6a144cdb009aef1a33824a0.tar.bz2
upstream-4c42e2d9dda739baa6a144cdb009aef1a33824a0.zip
include/meson: fix host build directory
When using a non default MESON_HOST_BUILD_DIR, HOST_BUILD_DIR is not appropriate to use. This change matches the target configure section. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'include/meson.mk')
-rw-r--r--include/meson.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/meson.mk b/include/meson.mk
index e101de4d89..102e74b542 100644
--- a/include/meson.mk
+++ b/include/meson.mk
@@ -98,7 +98,7 @@ define Host/Configure/Meson
--native-file $(HOST_BUILD_DIR)/openwrt-native.txt \
$(MESON_HOST_ARGS) \
$(MESON_HOST_BUILD_DIR) \
- $(HOST_BUILD_DIR), \
+ $(MESON_HOST_BUILD_DIR)/.., \
$(MESON_HOST_VARS))
endef