aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2018-12-16 10:45:53 +0100
committerZoltan HERPAI <wigyori@uid0.hu>2023-06-14 09:22:08 +0200
commit341e312ada4dda207a9f2c8402e73cc13b195983 (patch)
tree130d56e4e1773032cda3f7fe10c8d53342f37083 /include/kernel.mk
parent848759c2362fc60fef8aa76f2adeb228af3cae65 (diff)
downloadupstream-341e312ada4dda207a9f2c8402e73cc13b195983.tar.gz
upstream-341e312ada4dda207a9f2c8402e73cc13b195983.tar.bz2
upstream-341e312ada4dda207a9f2c8402e73cc13b195983.zip
generic: groundwork for RISC-V
Add build infrastructure for RISC-V. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> (cherry picked from commit 50c05f6cd721130701cbbc77a75d2e090259c4e5)
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index c657bf5d82..b1ae42534d 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -90,6 +90,8 @@ else ifneq (,$(findstring $(ARCH) , mipsel mips64 mips64el ))
LINUX_KARCH := mips
else ifneq (,$(findstring $(ARCH) , powerpc64 ))
LINUX_KARCH := powerpc
+else ifneq (,$(findstring $(ARCH) , riscv64 ))
+ LINUX_KARCH := riscv
else ifneq (,$(findstring $(ARCH) , sh2 sh3 sh4 ))
LINUX_KARCH := sh
else ifneq (,$(findstring $(ARCH) , i386 x86_64 ))