aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-12-16 11:04:27 +0000
committerJohn Crispin <blogic@openwrt.org>2012-12-16 11:04:27 +0000
commit631fa2c18c198add89566fdbcab66ccab80b126a (patch)
tree220390b7c792372ddfe81ea8620375a59e73a3b0 /include/kernel.mk
parent9383f6fa7dad77e4e096d9c0ec43be1649323b3b (diff)
downloadupstream-631fa2c18c198add89566fdbcab66ccab80b126a.tar.gz
upstream-631fa2c18c198add89566fdbcab66ccab80b126a.tar.bz2
upstream-631fa2c18c198add89566fdbcab66ccab80b126a.zip
[include] fixes uapi helper define
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34715 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index eabf9484fa..6185237765 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -35,8 +35,9 @@ else
endif
KERNEL_BUILD_DIR ?= $(BUILD_DIR)/linux-$(BOARD)$(if $(SUBTARGET),_$(SUBTARGET))
LINUX_DIR ?= $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)
- LINUX_UAPI_DIR=$(firstword $(wildcard $(LINUX_DIR)/include/uapi $(LINUX_DIR)/include))
-
+ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.7.0)),1)
+ LINUX_UAPI_DIR=uapi/
+ endif
LINUX_VERMAGIC:=$(strip $(shell cat $(LINUX_DIR)/.vermagic 2>/dev/null))
LINUX_VERMAGIC:=$(if $(LINUX_VERMAGIC),$(LINUX_VERMAGIC),unknown)