aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-10 13:41:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-10 13:41:00 +0000
commit443d4b872619902bb2457c5e2dbdb9e9786a9b14 (patch)
treef7f3e388a1ca574315eaf33368d8364d9aca72a5 /include/kernel.mk
parent58e3b95a2c1565981cbcd642ae5b3f8e8c0178b9 (diff)
downloadupstream-443d4b872619902bb2457c5e2dbdb9e9786a9b14.tar.gz
upstream-443d4b872619902bb2457c5e2dbdb9e9786a9b14.tar.bz2
upstream-443d4b872619902bb2457c5e2dbdb9e9786a9b14.zip
put LINUX_KARCH in .kernel.mk
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@5013 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk9
1 files changed, 1 insertions, 8 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index bd558ceec7..580e3951d1 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -17,6 +17,7 @@ else
ifeq ($(CONFIG_BOARD)-$(CONFIG_KERNEL),$(BOARD)-$(KERNEL))
LINUX_VERSION:=$(CONFIG_LINUX_VERSION)
LINUX_RELEASE:=$(CONFIG_LINUX_RELEASE)
+ LINUX_KARCH:=$(CONFIG_LINUX_KARCH)
else
# oops, old .kernel.config; rebuild it (hiding the misleading errors this produces)
$(warning rebuilding .kernel.mk)
@@ -30,14 +31,6 @@ else
LINUX_KMOD_SUFFIX=o
endif
- LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
- -e 's/mipsel/mips/' \
- -e 's/mipseb/mips/' \
- -e 's/powerpc/ppc/' \
- -e 's/sh[234]/sh/' \
- -e 's/armeb/arm/' \
- )
-
KERNELNAME=
ifneq (,$(findstring x86,$(BOARD)))
KERNELNAME="bzImage"