aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorJonas Gorski <jonas.gorski@gmail.com>2017-10-28 11:19:25 +0200
committerJonas Gorski <jonas.gorski@gmail.com>2017-10-28 11:19:25 +0200
commite5e5c3f5fd38f1f0dd8d4672fc64bdd0a1a01add (patch)
treebc9507b0cc55e84e14dc354b2b4dec12e899d17c /include/kernel.mk
parent471d5dc6e3c16a2bef9bde2b788b563a00357292 (diff)
downloadupstream-e5e5c3f5fd38f1f0dd8d4672fc64bdd0a1a01add.tar.gz
upstream-e5e5c3f5fd38f1f0dd8d4672fc64bdd0a1a01add.tar.bz2
upstream-e5e5c3f5fd38f1f0dd8d4672fc64bdd0a1a01add.zip
build: ensure PKG_INFO_DIR exists before trying to use it
PKG_INFO_DIR is only created at the finish step of the first package build, but kernel modules now use it at the start. Doing a parallel build could cause a kernel module to be the first package, breaking the build. Fix this by ensuring the directory exists. Fixes: 2e496876c60c ("kernel: collect module symvers for external modules") Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index f2099add53..f2d2a129d7 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -133,6 +133,7 @@ define populate_module_symvers
endef
define collect_module_symvers
+ @mkdir -p $(PKG_INFO_DIR)
for subdir in $(PKG_EXTMOD_SUBDIRS); do \
grep -F $(PKG_BUILD_DIR) $(PKG_BUILD_DIR)/$$$$subdir/Module.symvers >> $(PKG_BUILD_DIR)/Module.symvers.tmp; \
done; \